...

WebSAM JobCenter インポート・エクスポート機能 利用の手引き

by user

on
Category: Documents
0

views

Report

Comments

Transcript

WebSAM JobCenter インポート・エクスポート機能 利用の手引き
WebSAM JobCenter
インポート・エクスポート機能
利用の手引き
変更履歴
形式→(A:追加、C:修正、D:削除)
項番
変更日付
1
2
3
4
5
6
7
8
2004/5/31
2004/6/18
2004/6/18
2004/6/18
2004/6/18
2004/6/18
2004/6/18
2004/7/8
項目
新規作成
記述追加
記述追加
記述追加
記述追加
記述追加
記述追加
画面差替
形式
−
A
A
A
A
A
A
C
変更内容・理由
初版
2.2 ファイルパスについてに root/Administrator 記述追加
5.注意事項に記述を 4 項目追加
3.1.5, 4.1.3 に正常終了時の警告についての記述追加
3.3,4.3 にログファイル記述を追加
4.1.4 を追加
7.1.3 を追加
3.1.5,4.1.3 の依存性エラー時のダイアログ画面を差替え
目次
1.
はじめに ............................................................................................................. 1
2.
本マニュアルを読むにあたって .......................................................................... 2
2.1. 用語の説明.................................................................................................................. 2
2.2. ファイルパスについて ................................................................................................ 2
3.
エクスポート ...................................................................................................... 3
3.1. GUI による操作 .......................................................................................................... 3
3.1.1.
3.1.2.
3.1.3.
3.1.4.
3.1.5.
3.1.6.
3.1.7.
エクスポート画面.................................................................................................................. 3
エクスポート実行中 .............................................................................................................. 7
エクスポートデータの保存 ................................................................................................... 7
エクスポートデータの転送 ................................................................................................... 8
エクスポート結果(エラー、警告)..................................................................................... 8
エクスポートデータについて ............................................................................................. 10
注意事項 ...............................................................................................................................11
3.2. コマンドによる操作.................................................................................................. 11
3.2.1. エクスポートデータについて ..............................................................................................11
3.2.2. 注意事項 .............................................................................................................................. 12
3.3. ログファイル ............................................................................................................ 12
4.
インポート........................................................................................................ 13
4.1. GUI による操作 ........................................................................................................ 13
4.1.1. インポート画面 ................................................................................................................... 13
4.1.2. インポート実行中................................................................................................................ 18
4.1.3. インポート結果(エラー、警告) ...................................................................................... 18
4.1.4. インポートで使用するエクスポートデータ選択について .................................................. 19
4.1.5. MG(SV)に転送したエクスポートデータについて............................................................... 20
4.1.6. 注意事項 .............................................................................................................................. 20
4.2. コマンドによる操作.................................................................................................. 20
4.2.1.
4.2.2.
4.2.3.
4.2.4.
インポート対象選択エクスポートデータについて............................................................. 21
コマンドインタフェースで実行する場合のホスト名変換 .................................................. 21
ユーザ名の変換 ................................................................................................................... 21
注意事項 .............................................................................................................................. 22
4.3. ログファイル ............................................................................................................ 22
5.
その他注意事項................................................................................................. 23
6.
コマンドリファレンス ...................................................................................... 24
6.1. JNW のエクスポートコマンド ................................................................................... 24
6.2. JNW のインポートコマンド....................................................................................... 25
6.3. スケジュールエクスポートコマンド........................................................................ 25
6.4. スケジュールインポートコマンド ........................................................................... 26
6.5. カレンダエクスポートコマンド............................................................................... 27
6.6. カレンダインポートコマンド .................................................................................. 27
7.
付録 .................................................................................................................. 29
7.1. コマンドオプションと対象部品の関係 ..................................................................... 29
7.1.1. エクスポート対象部品 ........................................................................................................ 29
7.1.2. インポート対象部品 ............................................................................................................ 30
7.1.3. エラー発生時の対処について ............................................................................................. 31
1. はじめに
WebSam JobCenter(以下、JobCenter)インポート・エクスポート機能は、JobCenter 上の JNW 定
義、スケジュール定義、カレンダ定義のインポート・エクスポートを実現する為の機能です。
エクスポートの対象ファイルに付いては 7.付録・移行対象ファイルをご参照下さい。
1
2. 本マニュアルを読むにあたって
本書「WebSAM JobCenter インポート エクスポート利用の手引」では、次のような用語を用いて説
明しています。
2.1. 用語の説明
用語
ジョブ job
単位ジョブ unit job
ジョブネットワーク
job network:JNW
NQS
エクスポートファイル
キュー que
トラッカ tracker
説明
一括して実行するバッチとして記述したシェルスクリプトと資源制限
値、実行日時、優先順位などの属性などの指定をしたリクエストが最小
単位のジョブになります。これを単位ジョブとも呼んでいます。
複数のリクエスト間の実行順序を定義した単位ジョブを構成したもので
す。
Network Queuing System の略称。
リクエストを受け付けてキューイングし、順番に処理する機能です。
JNW、スケジュール、カレンダなどの部品の定義情報を格納した ZIP 形
式のエクスポートデータファイル(~.zip)と、エクスポート時の属性情報
を記述した属性定義ファイル(~.param)の二種類のファイルの総称です。
JobCenter が受け付けたリクエストをいったん、溜めておくものです。
JobCenter はこのキューに溜まっているリクエストを順番に実行してい
きます。
投入されたリクエストがどのマシンに転送され、実行し、終了したかと
いう情報を記録するそのリクエストを投入したマシン上のファイル(ト
ラッキングファイル)です。
2.2. ファイルパスについて
本書では、UNIX のファイルパス表記を前提に記述しています。Windows で使用する場合は、次のよ
うに読み替えて下さい。
・JobCenter ユーザ環境
UNIX の場合
ログインユーザ/NetShepEUI/
Windows の場合
JobCenter インストールディレクトリ¥SV¥jnwexe¥spool¥ログインユーザ¥
・コマンドパス
UNIX の場合
/usr/lib/nqs/gui/bin
Windows の場合
JobCenter インストールディレクトリ¥SV¥jnwexe¥lib¥
・ UNIX の root ユーザは、Windows の場合 Administrator ユーザとして読み替えて下さい。
2
3. エクスポート
3.1. GUI による操作
CL/Win でエクスポートしたいデータがあるマシンに接続し、ユーザフレーム、マネージャフレーム、
NQS フレームのいずれかのフレームウィンドウを開きます。
その後、次の操作によりエクスポートの画面をそれぞれ表示します。
(なお、接続するユーザにより実行できる機能が異なります。詳細は 3.1.7 注意事項をご参照下さい)
3.1.1. エクスポート画面
・JNW のエクスポート
[ファイル]-[エクスポート]-[JNW のエクスポート]
3
パラメータ項目:
„ 全ユーザ全 JNW をエクスポート
全ユーザの全 JNW、全スケジュール、全共有 JNW、全カレンダが対象となります。
„ 個別指定
„ 共有 JNW をエクスポート
全共有 JNW が対象となります。
„ ユーザ指定
„ ユーザ一覧 (”全ユーザ”選択時)
全ユーザの全 JNW が対象となります。
„ ユーザ一覧 (ユーザ選択時)
„ 全ての JNW をエクスポート
ユーザ一覧で指定したユーザの全 JNW が対象となります。
„ 指定したグループの JNW をエクスポート
「JNW のエクスポート」画面中に表示されたグループのリストから選択し
たグループに属する JNW が対象となります。指定したグループ配下のグル
ープに属する JNW は全て対象となります。
„
„
„
„
指定した JNW をエクスポート
「JNW のエクスポート」画面中に表示された JNW のリストから選択した
JNW が対象となります。
Sub
JNW をエクスポート
エクスポート対象の JNW に Sub
JNW が定義されている場合に、その Sub
JNW をエクスポート対象に「する」
、「しない」を選択します。
関連するスケジュールをエクスポート
エクスポート対象の JNW にカレンダ分岐部品が定義されている場合に、カレン
ダ分岐部品で指定されたスケジュールをエクスポート対象に「する」、
「しない」
を選択します。(ただし当該 JNW があるスケジュールで関連 JNW に指定され
ている場合、そのスケジュールは対象になりません)
関連するカレンダをエクスポート
エクスポート対象のスケジュールに適用されているカレンダがある場合、その
カレンダをエクスポート対象に「する」
、
「しない」を選択します。
4
・スケジュールのエクスポート
[ファイル]-[エクスポート]-[スケジュールのエクスポート]
パラメータ項目:
„ 全ユーザのスケジュールエクスポート
全ユーザの全スケジュールが対象となります。
„ ユーザ指定
„ ユーザ一覧
エクスポート対象のユーザを選択します。
„ 全スケジュールエクスポート
ユーザ一覧で選択したユーザの全スケジュールが対象となります。
„ 個別指定
「スケジュールのエクスポート」画面中に表示されたスケジュールのリストから選
択したスケジュールが対象となります。
5
・カレンダのエクスポート(接続ユーザが root, nsumsmgr の場合のみ選択可)
[ファイル]-[エクスポート]-[カレンダのエクスポート]
パラメータ項目:
„ 全カレンダのエクスポート
全カレンダが対象となります。
„ 個別指定
「カレンダのエクスポート」画面中に表示されたカレンダのリストから選択したカレンダ
が対象となります。
6
3.1.2. エクスポート実行中
エクスポートする対象を選択して実行ボタンをクリックすると、MG(SV)でエクスポート処理を
実行します。MG(SV)でのエクスポート処理中は以下の画面が表示されます。
正常に処理が終了すると、3.1.3 のエクスポートデータの保存画面が表示されます。
3.1.3. エクスポートデータの保存
エクスポートが完了すると、CL/Win の動作する PC 上の任意の場所にエクスポートデータを保存す
ることができます。エクスポート先の確定画面で、エクスポートデータの保存先フォルダを指定して
ください。任意の名前のフォルダを指定すると、エクスポートデータがそのフォルダ内に保存されま
す。(保存されるデータの種類については 3.1.6 をご参照下さい)
なおすでに同名のフォルダが存在していた場合はエラーになります。
7
3.1.4. エクスポートデータの転送
エクスポートデータの保存先フォルダを指定しOKをクリックすると、MG(SV)で作成したエクスポー
トデータを転送します。
エクスポートデータの転送中は以下の画面が表示されます。
ファイルの転送が終わると画面を閉じます。続いてエラー、警告メッセージの表示が無ければ正常終
了です。
3.1.5. エクスポート結果(エラー、警告)
MG(SV)上のエクスポート実行中。又は、エクスポートファイル転送中に処理続行不可のエラーが
発生した場合に表示されます。詳細は 7.付録の”エラー発生時の対処について”をご参照ください。
指定した条件ではエクスポート対象となる JNW、スケジュール、カレンダが1件もない場合に表
示されます。指定を見直して下さい。
8
JNW の依存関係に矛盾がある場合に表示されます。
(例:カレンダ分岐部品で設定されたスケジュールが無い、定義された Sub JNW の実体が無い等)
“ ログインユーザ/NetShepEUI/exportfile/”に表示された“.log”ファイルが作成されています。
ログファイルのメッセージを確認し、JNW 定義の矛盾点を修正してから再度エクスポートを実施
して下さい。
9
3.1.6. エクスポートデータについて
GUI による操作の場合、エクスポートを実行すると MG(SV)上で、まず
ログインユーザ/NetShepEUI/exportfile/
配下に次のようにテンポラリファイルを作成します。
・JNW のエクスポート
JNW_HOSTNAME_YYYYMMDDHHMMxxx ディレクトリを作成し、以下のファイル名で
格納
JNW_HOSTNAME_YYYYMMDDHHMMxxx.zip : エクスポートデータファイル
JNW_HOSTNAME_YYYYMMDDHHMMxxx.param : 属性定義ファイル
・スケジュールのエクスポート
SCH_HOSTNAME_YYYYMMDDHHMMxxx ディレクトリを作成し、以下のファイル名で
格納
SCH_HOSTNAME_YYYYMMDDHHMMxxx.zip : エクスポートデータファイル
SCH_HOSTNAME_YYYYMMDDHHMMxxx.param : 属性定義ファイル
・カレンダのエクスポート
CAL_HOSTNAME_YYYYMMDDHHMMxxx ディレクトリを作成し、以下のファイル名で
格納
CAL_HOSTNAME_YYYYMMDDHHMMxxx.zip : エクスポートデータファイル
CAL_HOSTNAME_YYYYMMDDHHMMxxx.param : 属性定義ファイル
注) HOSTNAME
: 実行ホスト名
YYYYMMDDHHMM : コマンド起動時刻(年月日時分)
xxx
: 0 から 999 までの番号
ユーザのホームディレクトリに上記エクスポートデータとテンポラリファイルが一時的に格納出来る
容量が確保出来ない場合、エラーになります。
これらのファイルは CL/Win の操作でエクスポートファイルを保存し正常終了した場合、またはエク
スポート操作をキャンセルし[MG(SV)上のエクスポートファイルを削除しますか?]ダイアログで[は
い]を選択した場合に削除されます。
エクスポート操作キャンセルで[MG(SV)上のエクスポートファイルを削除しますか?]ダイアログで
[いいえ]を選択した場合、データは削除されず MG(SV)上にそのまま残ります。その場合、不要になっ
た時点で随時削除して下さい。
10
3.1.7. 注意事項
・ root および nsumsmgr で接続してエクスポートを実行した場合は全ての機能が利用出来ます
が、一般ユーザで実行した場合はログインユーザの JNW、スケジュールのみがエクスポート対
象となります。一般ユーザで操作する場合、利用出来ない機能については画面上でグレーアウト
し、操作出来ません。
・ ユーザ一覧や部品の個別指定では、選択できる対象は1つのみです。複数選択はできません。
3.2. コマンドによる操作
MG(SV)にログインし、コマンドライン上でそれぞれ次のコマンドを実行します。
・JNW のエクスポート
/usr/lib/nqs/gui/bin/jnw_export
・スケジュールのエクスポート
/usr/lib/nqs/gui/bin/sch_export
・カレンダのエクスポート(root ユーザのみ)
/usr/lib/nqs/gui/bin/cal_export
CL/Win へのエクスポートデータ転送機能を除いて、基本的に 1.1 項の GUI 操作と同等の機能を
提供します。
コマンド起動時のエクスポート対象選択に関してはコマンドラインのオプション指定で行いま
す。詳細は 6. コマンドリファレンスおよび 7.付録をご参照下さい。
3.2.1. エクスポートデータについて
GUI による操作と同様、
ログインユーザ/NetShepEUI/exportfile/
配下にテンポラリファイルを作成します。詳細は 3.1.6 をご参照下さい。
11
3.2.2. 注意事項
1) root でログインしてコマンドを実行した場合は全てのオプションが利用出来ますが、その他の
ユーザ(nsumsmgr を含む)で実行する場合、UNIX の実行ユーザ権限に依存します。
・全ユーザ JNW エクスポート
・共有 JNW エクスポート
・カレンダエクスポート
などを行なう場合は必ず root でログインしてください。
2) エクスポート対象ユーザに付いて
UNIX の場合、次の 2 つの条件を同時に満たしたユーザがエクスポート対象になります。
1) SV のユーザホームディレクトリ配下に NetShepEUI ディレクトリが存在する。
2) 環境構築後 Win/CL から接続され、/usr/spool/nqs/gui 配下に該当ユーザ名でシンボリ
ックリンクが作成されている。
Windows の場合、次の条件を満たしたユーザがエクスポート対象になります。
¥JobCenter¥SV¥jnwexe¥spool フォルダ配下に該当ユーザ名でフォルダが作成されている
事。
3.3. ログファイル
実行時ログファイルは、
ログインユーザ/NetShepEUI/exportfile/
配下に、JNW_HOSTNAME_YYYYMMDDHHMMxxx.log として格納します。
このファイルはエラーログファイルはコマンド起動毎に 1 ファイル作成します。単調増加ファイ
ルではなく、コマンドが終了すればそれ以上サイズが増加することはありません。
インポート・エクスポート機能では削除しませんので、不要になったログファイルは随時削除し
て下さい。
12
4. インポート
4.1. GUI による操作
CL/Win でデータをインポートしたいマシンに接続し、ユーザフレーム、マネージャフレーム、NQS
フレームのいずれかのフレームウィンドウを開きます。
その後、次の操作によりインポートの画面をそれぞれ表示します。
(なお、接続するユーザにより実行できる機能が異なります。詳細は 4.1.6 注意事項をご参照下さい)
4.1.1. インポート画面
・JNW のインポート
[ファイル]-[インポート]-[JNW のインポート]
パラメータ項目:
„ 全ユーザインポート
エクスポートファイル中の、全ユーザの全JNW、全ユーザの全スケジュール、全共有
JNW、全カレンダが対象となります。
„ 共有JNW
エクスポートファイル中の、共有JNWが対象となります。
„ ユーザ指定
ユーザ一覧で選択したユーザが対象となります。エクスポート時、ユーザ指定で実行し
たエクスポートファイルの場合で、エクスポート時と違うユーザを指定しインポートし
た場合、インポート時指定したユーザのデータに変換しながらインポートします。
13
インポートの指定後、OKを押すとインポート元フォルダの指定画面が表示されます。
インポートするファイルが存在するフォルダを指定しOKを押して下さい。
無効なフォルダを指定した場合は、以下の“指定したファイルが存在しません”のメッセー
ジが表示されます。
“OK”を押し再度フォルダの指定を行って下さい。
14
パラメータ項目:
„ 移行元マシン名一覧
エクスポートファイル中の、JNW、スケジュール中に存在するホスト名を表示します。
„ 移行先マシン名一覧
接続マシンの MG(SV)のマシングループに登録されたマシン名を表示します。
„ 追加ボタン
移行元マシン、移行先マシンを選択し、追加ボタンを押すと マシン名変更の一覧に追
加されます。
すでに登録済みの場合は“指定したマシンは既に存在しています。
”のメッセージが表示
されます。
„
削除ボタン
マシン名変更の一覧から削除したい行を選択し、削除ボタンを押すとマシン名変更の一
覧から選択したマシン名が削除されます。
15
・スケジュールのインポート
[ファイル]-[インポート]-[スケジュールのインポート]
パラメータ項目:
„ 全ユーザのスケジュールインポート
エクスポートファイル中の、全ユーザの全スケジュールが対象となります。
„ ユーザ指定
ユーザ一覧で選択したユーザが対象となります。エクスポート時、ユーザ指定で実行し
たエクスポートファイルの場合で、エクスポート時と違うユーザを指定しインポートし
た場合、インポート時指定したユーザのデータに変換しながらインポートします。
インポートの指定後、OKを押すとインポート元フォルダの指定画面が表示されます。
インポートするファイルが存在するフォルダを指定しOKを押して下さい。
16
無効なフォルダを指定した場合は、以下の“指定したファイルが存在しません”のメッセー
ジが表示されます。
“OK”を押し再度フォルダの指定を行って下さい。
・カレンダのインポート(接続ユーザが root, nsumsmgr の場合のみ選択可)
[ファイル]-[インポート]-[カレンダのインポート]
無効なフォルダを指定した場合は、以下の“指定したファイルが存在しません”のメッセー
ジが表示されます。
“OK”を押し再度フォルダの指定を行って下さい。
17
4.1.2. インポート実行中
インポートする対象を選択して実行ボタンをクリックすると、MG(SV)へインポートするデータ
の転送に続き、インポート処理を実行します。ファイル転送中、MG(SV)でのインポート処理中は
以下の画面が表示されます。正常に処理が終了すると、画面が消えます。
続いてエラー、警告メッセージの表示が無ければ正常終了です。
各画面が表示されたら CL/Win が動作する PC 上の任意のフォルダを選択し、実行ボタンを選択
して下さい。インポートが完了すると、[表示]-[最新表示]によりインポートした部品を確認すること
ができます。
4.1.3. インポート結果(エラー、警告)
MG(SV)上のエクスポート実行中。又は、エクスポートファイル転送中に処理続行不可のエラーが
発生した場合に表示されます。詳細は 7.付録の”エラー発生時の対処について”をご参照くださ
い。
18
次の画面はインポート処理自体は正常終了してますが、JNW の依存関係に矛盾がある場合に表示
されます。
(例:カレンダ分岐部品で設定されたスケジュールが無い、定義された Sub JNW の実体が無い等)
“ ログインユーザ/NetShepEUI/exportfile/”に表示された“.log”ファイルが作成されています。
ログファイルのメッセージを確認し、JNW 定義の矛盾点を修正してから再度エクスポートを実施
して下さい。
4.1.4. インポートで使用するエクスポートデータ選択について
インポート対象を選択し、[OK]を選択するとインポート元フォルダの指定画面が表示されます。
インポート対象フォルダを選択し、[OK]ボタンを選択すると[マシン名変更]画面が表示されます。
データに含まれるマシン名を変更しながらインポートしたい場合は、それぞれの変換規則を追加し
てから実行してください。
インポート元フォルダとして、任意の名前を付けることができます。そのフォルダに格納したデ
ータファイルについては次の規則に従ってファイル名を付けて格納してください。
・ データ名(*.zip, *.param)と格納フォルダ名は、拡張子以外は同じ名前とします。
(例) D:¥JNW_import¥JNW_import.zip
JNW_import.param
のように格納し、GUI で D:¥JNW_import を選択
19
4.1.5. MG(SV)に転送したエクスポートデータについて
インポート実行でエクスポートデータを MG(SV)に転送し、
ログインユーザ/NetShepEUI/exportfile/
配下にテンポラリファイル(import.zip, import.param, import.rule)を作成します。
MG(SV)上のユーザのホームディレクトリに上記エクスポートデータとテンポラリファイルが一時
的に格納出来る容量が確保出来ない場合、エラーになります。
4.1.6. 注意事項
root および nsumsmgr で接続してインポートを実行した場合は全ての機能が利用出来ますが、一般
ユーザで実行した場合はログインユーザの JNW、スケジュールのみがインポート対象となります。一
般ユーザで操作する場合、利用出来ない機能については画面上でグレーアウトし、操作出来ません。
また、何らかの原因でインポートがエラーになった場合、MG(SV)に転送されたエクスポートデー
タは自動的には削除されませんのでご注意ください。
4.2. コマンドによる操作
MG(SV)にログインし、コマンドライン上でそれぞれ次のコマンドを実行します。
・JNW のインポート
/usr/lib/nqs/gui/bin/jnw_import
・スケジュールのインポート
/usr/lib/nqs/gui/bin/sch_import
・カレンダのインポート(root ユーザのみ)
/usr/lib/nqs/gui/bin/cal_import
CL/Win からのエクスポートデータ転送機能を除き、基本的に 2.1 項の GUI 操作と同等の機能を
提供します。
20
4.2.1. インポート対象選択エクスポートデータについて
コマンド起動時のインポート対象選択に関してはコマンドラインの -d オプションで絶対パ
ス、または相対パスでデータ格納ディレクトリを指定します。任意のディレクトリに任意のエク
スポートデータを格納する規則については 4.1.4 をご参照下さい。
-d オプションを指定しない場合は
ログインユーザ/NetShepEUI/exportfile/temp/import.zip
import.param
import.rule (4.2.2 参照)
のディレクトリとデータが既定値となります。
4.2.2. コマンドインタフェースで実行する場合のホスト名変換
JNW の中に記述してあるホスト名の変換が必要な場合、import.rule ファイルを作成して下さい。
(ファイル名は 3.1.6 の規則に従い、最後に識別子 .rule を付けて下さい)
・ フォーマット
"移行元ホスト名 移行先ホスト名"
"移行元ホスト名 移行先ホスト名"
・
・
移行元ホスト名 + 半角ブランク + 移行先ホスト名で 1 レコードとし、全体をダブルクォー
トで囲んだテキスト形式のファイルを作成します。変換規則が複数ある場合は、改行して複数
行指定して下さい。
4.2.3. ユーザ名の変換
管理者で接続してユーザ指定でエクスポートしたデータ(あるいは一般ユーザで接続してロ
グインユーザをエクスポートしたデータ)を、ユーザ指定(あるいはログインユーザ)でイン
ポートする場合、エクスポート時と違うユーザ名を指定すると、各部品を指定したユーザ名に
変換しながらインポートします。
21
4.2.4. 注意事項
1) root でログインしてコマンドを実行した場合は全てのオプションが利用出来ますが、その他の
ユーザ(nsumsmgr を含む)で実行する場合、UNIX の実行ユーザ権限に依存します。
・全ユーザ JNW インポート
・共有 JNW インポート
・カレンダインポート
などを行なう場合は必ず root でログインしてください。
2) root も含めて、インポート対象となるユーザで必ず最低 1 度は CL/Win で MG(SV)に接続し、
ユーザのホームディレクトリ配下に NetShepEUI 環境が構築されていることを確認してくださ
い。
NetShepEUI 配下の環境が無いユーザでコマンドによる操作を行なうとエラーになります。
4.3. ログファイル
実行時ログファイルは、
ログインユーザ/NetShepEUI/exportfile/
配下に、JNW_HOSTNAME_YYYYMMDDHHMMxxx.log として格納します。
エラーログファイルはコマンド起動毎に 1 ファイル作成します。単調増加ファイルではなく、コ
マンドが終了すればそれ以上サイズが増加することはありません。
このファイルはインポート・エクスポート機能では削除しません。不要になったログファイルに
ついて随時削除して下さい。
22
5. その他注意事項
・ インポートは他の GUI 接続による操作や、ジョブが実行中で無いことを確認した上で実行して下
さい。また、インポート実行中にジョブが投入されるようなスケジュールが設定されていない事
を確認して下さい。他のユーザが GUI 操作により JNW 定義やスケジュール、カレンダを修正中に
インポートを実行しますと、思わぬ依存性関係の不具合を起こす場合があります。
・ インポート時にすでに MG(SV)上に同名の JNW、スケジュール、カレンダが存在した場合、元のデ
ータを消去してからインポートします。上書きされると困る部品についてはあらかじめ名前を変
更するか、エクスポートにより別途バックアップを取っておいてください。
・ クラスタ環境においてインポート・エクスポート機能を使用する場合は、他の JobCenter コマン
ドの利用方法に準じます。詳細は”WebSAM JobCenter 利用の手引き 6.7 クラスタ構成”をご
参照下さい。
・ JNW 数や単位ジョブスクリプトのサイズなど、エクスポート、インポートに要する時間は環境に
より大きく異なります。GUI I/F で実行する場合は、CL/Win の[設定]-[通信タイムアウト時間設定]の
値を環境に合わせて適切に変更してください。事前に MG (SV)上でコマンドライン I/F により同
条件で処理を実行した際の時間を計測して目安とするのが確実です。(例:HP rp2470-650MHz で
単位ジョブ 1000 件、10MB のファイル容量の条件で、MG (SV)上の処理時間はエクスポートで約
10-12 秒、インポートで約 27 秒)
・ 各ユーザの JobCenter 環境配下の、JNW ファイル格納ディレクトリ( /NetShepEUI/nsjnw)に、JNW
と関係の無い不要なファイル、ディレクトリを作成しないで下さい。スケジュール格納ディレク
トリ( /NetShepEUI/indcal)、共有 JNW 格納ディレクトリ(/usr/spool/nqs/gui/cmn.d.C)、カレ
ンダ格納ディレクトリ((/usr/spool/nqs/gui/wkcal.d)についても同様です)
・ グループ指定でエクスポートしたデータをインポートする場合、データに含まれるグループの階
層構造はそのまま復元されますが、インポート先の既存のグループ名との表示順序は順不同にな
ります。表示順序の変更は、ユーザフレームの右側でグループ名を右クリックして[順序の変更]
により行なってください。
・ ショートカットしか含まないグループを指定したエクスポートはできません。必ず JNW を最低 1
つ含むグループを作成して指定してください。
23
6. コマンドリファレンス
6.1. JNW のエクスポートコマンド
【形式】
jnw_export [{ -a │ -j │ -ua }] [-sj] [-s] [-c]
jnw_export [-u username { -ja │ -g groupname │ -j jnwname }] [-sj] [-s] [-c]
【機能説明】
指定したパラメータにより、JNW をエクスポートします。各オプションとエクスポートされる部
品との関係は、「7.1.1 エクスポート対象部品」を参照してください。
【オプション】
オプション無し : ログインユーザのすべての JNW をエクスポートします。
-a : すべてのユーザの JNW、共有 JNW、スケジュール、カレンダをエクスポートします。
このオプションはルートユーザのみ使用できます。
-j : すべての共有 JNW をエクスポートします。
このオプションはルートユーザのみ使用できます。
-ua : すべてのユーザの JNW をエクスポートします。
このオプションはルートユーザのみ使用できます。
-u : エクスポートしたい定義ファイルを持つユーザ名を指定します。
-ja : -u オプションとともに使用し、指定したユーザがもつすべての JNW をエクスポート
します。
-g : -u オプションとともに使用し、指定したユーザがもつ指定したグループの JNW をエ
クスポートします。
-j : -u オプションとともに使用し、指定したユーザがもつ指定した JNW をエクスポート
します。
-sj : -ua または-u オプションとともに使用し、対象となる JNW の Sub JNW をエクスポート
します。
-s : -ua または-u オプションとともに使用し、対象となる JNW に関連するスケジュールを
エクスポートします。
-c : -ua または-u オプションとともに使用し、対象となる JNW に関連するカレンダをエク
スポートします。
username : エクスポート対象の JobCenter のユーザ名を指定します。
(複数指定はできません。)
groupname : エクスポート対象のグループ名を指定します。(複数指定はできません。)
なお、グループ名は、ドット(.)で始まり, .GroupName1 の形式で指定します。また、
階層化されたグループの場合は、親グループ名から順にドット(.)で各階層のグル
ープ名を連結して、.GroupName1.GroupName2 の形式で指定します。
jnwname : エクスポート対象の JNW 名を指定します。(複数指定はできません。)
【戻り値】
0:正常終了 1:異常終了
24
【エラーメッセージ】
エ ラ ー メ ッ セ ー ジ は 、 “ /usr/spool/nqs/gui/ ユ ー ザ 名
/exportfile/JNW_HOST_YYYYMMDDHHMMxxx.log” (xxx は 001 から 999 の順で作成します)に出力
します。“YYYYMMDDHHMM”の部分は JNW エクスポートコマンド起動時刻となります。
6.2. JNW のインポートコマンド
【形式】
jnw_import [-a │ -j] [-d dirname]
jnw_import [-u username] [-d dirname]
【機能説明】
エクスポートした JNW のデータファイルから JNW をインポートします。
【オプション】
オプション無し : ログインユーザに JNW をインポートします。
-a : インポート用データファイルにあるすべての JNW、共有 JNW、スケジュール、カレンダ
をインポートします。ただし、インポート先に存在しないユーザに関連するものはインポ
ートしません。このオプションはルートユーザのみ使用できます。
-j : 全共有 JNW をインポートします。このオプションはルートユーザのみ使用できます。
-u : 指定したユーザにインポートします。
-d : エクスポートしたデータファイルがあるディレクトリを指定します。指定するディレ
クトリの詳細は、
「4.1.4 インポートで使用するエクスポートデータ選択について」を参照し
てください。
username : インポート対象の JobCenter のユーザ名を指定します。(複数指定はできません。)
【戻り値】
0:正常終了 1:異常終了
【エラーメッセージ】
エ ラ ー メ ッ セ ー ジ は 、 “ /usr/spool/nqs/gui/ ユ ー ザ 名
/exportfile/JNW_HOST_YYYYMMDDHHMMxxx.log” (xxx は 001 から 999 の順で作成します)に出力
します。“YYYYMMDDHHMM”の部分は JNW インポートコマンド起動時刻となります。
6.3. スケジュールエクスポートコマンド
【形式】
sch_export -a
sch_export -u username {-sa │ -s schedule}
【機能説明】
スケジュールをエクスポートします。
25
【オプション】
オプション無し : ログインユーザの全スケジュールをエクスポートします。
-a : 全ユーザのスケジュールをエクスポートします。このオプションはルートユーザのみ
使用できます。
-u : エクスポート対象となるユーザを指定します。
-sa : -u オプションとともに使用し、指定したユーザのスケジュールをエクスポートしま
す。
-s : -u オプションとともに使用し、指定したユーザの指定したスケジュールをエクスポ
ートします。
username : エクスポート対象の JobCenter のユーザ名を指定します。(複数指定はできませ
ん。)
schedule : エクスポート対象のスケジュール名を指定します。(複数指定はできません。)
【戻り値】
0:正常終了 1:異常終了
【エラーメッセージ】
エ ラ ー メ ッ セ ー ジ は 、 “ /usr/spool/nqs/gui/ ユ ー ザ 名 /exportfile/
SCH_HOST_YYYYMMDDHHMMxxx.log” (xxx は 001 から 999 の順で作成します)に出力します。
“YYYYMMDDHHMM”の部分はスケジュールエクスポートコマンド起動時刻となります。
6.4. スケジュールインポートコマンド
【形式】
sch_import [-a] [-d dirname]
sch_import [-u username] [-d dirname]
【機能説明】
エクスポートしたデータファイルから、スケジュールをインポートします。
【オプション】
オプション無し : ログインユーザにすべてのスケジュールをインポートします。
-a : すべてのユーザのスケジュールをインポートします。このオプションはルートユーザ
のみ使用できます。
-u : 指定したユーザにインポートします。
-d : エクスポートしたデータファイルがあるディレクトリを指定します。指定するディレ
クトリの詳細は、
「4.1.4 インポートで使用するエクスポートデータ選択について」を参照し
てください。
username : インポート対象の JobCenter のユーザ名を指定します。(複数指定はできません。)
【戻り値】
0:正常終了 1:異常終了
【エラーメッセージ】
26
エ ラ ー メ ッ セ ー ジ は 、 “ /usr/spool/nqs/gui/ ユ ー ザ 名 /exportfile/
SCH_HOST_YYYYMMDDHHMMxxx.log” (xxx は 001 から 999 の順で作成します)に出力します。
“YYYYMMDDHHMM”の部分はスケジュールインポートコマンド起動時刻となります。
6.5. カレンダエクスポートコマンド
【形式】
cal_export [-c calendar]
【機能説明】
カレンダをエクスポートします。
【オプション】
オプション無し : すべてのカレンダをエクスポートします。
-c : 指定したカレンダをエクスポートします。
calendar : エクスポートするカレンダを指定します。
【戻り値】
0:正常終了 1:異常終了
【エラーメッセージ】
エ ラ ー メ ッ セ ー ジ は 、 “ /usr/spool/nqs/gui/ ユ ー ザ 名 /exportfile/
CAL_HOST_YYYYMMDDHHMMxxx.log” (xxx は 001 から 999 の順で作成します)に出力します。
“YYYYMMDDHHMM”の部分はカレンダエクスポートコマンド起動時刻となります。
6.6. カレンダインポートコマンド
【形式】
cal_import [-d dirname]
【機能説明】
カレンダをインポートします。
【オプション】
-d : エクスポートしたデータファイルがあるディレクトリを指定します。指定するディレ
クトリの詳細は、
「4.1.4 インポートで使用するエクスポートデータ選択について」を参照し
てください。
【戻り値】
0:正常終了 1:異常終了
【エラーメッセージ】
27
エ ラ ー メ ッ セ ー ジ は 、 “ /usr/spool/nqs/gui/ ユ ー ザ 名 /exportfile/
CAL_HOST_YYYYMMDDHHMMxxx.log” (xxx は 001 から 999 の順で作成します)に出力します。
“YYYYMMDDHHMM”の部分はカレンダインポートコマンド起動時刻となります。
28
7. 付録
7.1. コマンドオプションと対象部品の関係
7.1.1. エクスポート対象部品
エクスポート時のオプション
JNW
-a
-j
-ua
-u username -ja
-u username -g groupname
-u username -j jnwname
オプションなし
○
対象部品
共有JNW
スケジュール
○
○
○
○
○
○
○
○
○
○
29
備考
カレンダ
○
全ユーザ対象
全ユーザ対象
7.1.2. インポート対象部品
エクスポート時の インポート時の
オプション
オプション
-a
-a
-j
-u username
オプションなし
-j
-a
-j
-u username
オプションなし
-ua
-a
-j
-u username
オプションなし
-u username -ja -a
-j
-u username
オプションなし
-u username
-a
-g groupname
-j
-u username
オプションなし
-u username
-a
-j jnwname
-j
-u username
オプションなし
オプションなし -a
-j
-u username
オプションなし
対象部品
JNW 共有JNW スケジュール
○
○
○
○
○
○
備考
カレンダ
○
全ユーザ対象
○
○
指定ユーザ
ログインユーザ
○
○
なし
なし
全ユーザ対象
なし
指定ユーザ
ログインユーザ
○
○
○
○
○
○
なし
ユーザ名変換
ユーザ名変換
○
○
○
なし
○
○
○
なし
○
○
○
○
なし
○
○
○
○
30
7.1.3. エラー発生時の対処について
処理続行不可のエラーが発生した場合、ログファイルのエラーメッセージの内容により障害内
容をその都度判断して必要なオペレーションを実行し、障害を解消する必要があります。
また*.zip ファイルや*.param ファイルの転送に失敗してエラーで停止した場合は、SV 上にこれ
らのファイルが残ります。
(データ保存の観点より、正常終了の時と違いエラー発生時には自動で削除されません)
必要であればエラー発生後の再実行の前にこれらのファイルの存在を確認し、削除してください。
また、インポート・エクスポート処理実行中に処理続行不可のエラーが発生した場合“~ログイン
ユーザ/NetShepEUI/exportfile/temp”にファイルが残る場合があります。(障害解析に必要なた
め)処理続行不可のエラー発生時には“~ログインユーザ/NetShepEUI/exportfile/temp”以下お
よびログファイルをバックアップしたのち、消去してください。
31
Fly UP